エラー: 処理を完了できませんでした (無効または破損したパッケージ (PGP 鍵))

ブログタイトル考えるのが適当すぎるけどまあいいかな

最近メインマシンにおさがりのSSDをつけた記念にメインでつかうディストリをFedoraからAntergosにしてみました
はじめてのArch系(?)です

早速アップデート中によくわからないエラーに遭遇したので備忘録的にまとめておきます
pacmanでもyaourtでも同じエラーが出たのですがとりあえずpacmanで書いておきます

おなじみのアップデート

sudo pacman -Syu

すると
インストールを行いますか? のあとで

ファイル [該当のファイルの場所が入ります] は破損しています (無効または破損したパッケージ (PGP 鍵))。
ファイルを削除しますか? [Y/n]

とでてきます。なんだこれは
で、適当にYesとかNoとか入力していると

エラー: 処理を完了できませんでした (無効または破損したパッケージ (PGP 鍵))
エラーが発生したため、パッケージは更新されませんでした。

となってうまく更新できない
自分はこのときエラーを起こしたパッケージはすべてantergosのリポジトリのものでした
適当なワードでググっていたら解決方法が見つかりました

PGP鍵というワードが含まれているのでとりあえずパッケージのキーを確認するという方向です

sudo pacman-key --refresh-keys

これで最新のキーに更新

sudo pacman-key --populate archlinux antergos

archlinuxのキーまで取得する必要はないかもしれませんがとりあえず

sudo paccache -ruk0

おそらくこれは実行する必要はないと思うのですがパッケージキャッシュの削除
pacman -Sc よりも paccacheのほうが良いみたい

こんな感じでまた pacman -Syuしてあげたらちゃんと更新してくれました
ディレクトリのパーミッションが異なっていますとかいう警告がでたけどきにしない。。

TwitterにはArchマスターなフォロワーさんがたくさんいるのでぜひ間違っているところあれば指摘ください
個人的にまたこういうケースに遭遇しそうなので備忘録としてまとめておきました

・参考にしたサイト
ArchWiki など

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

次のHTML タグと属性が使えます: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>